Investigating Service Interruptions - Ipplepen

Incident Report for Wildanet Limited

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 10:29 UTC

Investigating

We're aware of service interruptions affecting the Ipplepen area. We are actively working on identifying the problem, please check back for updates.

Should your Wildanet account have your updated mobile number and email address, you will have also received this notice electronically and via SMS. You can ensure we have your current details by emailing hello@wildanet.com along with your service address or account number beginning with CExxx.

We apologise for any inconvenience caused by this service interruption.
Posted Apr 22, 2026 - 07:18 UTC