National Grid Service Interruption

Incident Report for Wildanet Limited

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 15:54 UTC

Identified

Please be aware that there is a current National Grid power outage affecting the area of Constantine and the following postcodes: TR11 5AG and TR12 7AE.
As a result, you may be experiencing a loss of service. National Grid has identified the cause and is currently working to resolve the issue. Service restoration is currently estimated for 4pm.
Posted Apr 17, 2026 - 14:06 UTC