Liskeard PL14 Power Cut

Incident Report for Wildanet Limited

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 17:34 UTC

Update

We are continuing to investigate this issue.
Posted Apr 23, 2026 - 17:34 UTC

Investigating

We are aware of a service disruption affecting customers in the Liskeard area.
The issue has been identified as a third party power outage impacting our network equipment.
We are monitoring the situation which should be resolved by 1430 on Thursday 23rd of April 2026.
Posted Apr 23, 2026 - 12:29 UTC