Investigating Service Interruptions

Incident Report for Wildanet Limited

Resolved

We recently experienced a service interruption in Turbine Tower - this has now been resolved and your connection should have returned to normal.
If you experience any ongoing issues please contact us on customer.services@wildanet.com
Posted Feb 28, 2026 - 10:27 UTC

Investigating

We're aware of interruptions effecting the FWA service feeding Gweek Boatyard, Gweek Chapel and Constantine and we are actively working on identifying the problem, please check back for updates.
Posted Feb 27, 2026 - 17:14 UTC